import Foundation
let pattern = #"\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/*ext-${vscode-rickroll}-start*/
@keyframes doRick{
from {
transform: scale(2);
opacity:1;
}
to {
transform: scale(1);
opacity:0.7;
}
}
body{
animation: doRick 1.8s linear 1 normal forwards;
background-size:contain;
opacity:1;
animation-delay: 2.4s;
background-repeat: no-repeat;
background-position:center center;
background-image:url('${base64image}');
}
/*ext-${vscode-rickroll}-end*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)