import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*ext-vscode-rickroll-start\\*\\/[\\s\\S]*?\\/\\*ext-vscode-rickroll-end\\*\\/";
final String string = "/*ext-${vscode-rickroll}-start*/\n"
+ "@keyframes doRick{\n"
+ " from {\n"
+ " transform: scale(2);\n"
+ " opacity:1;\n"
+ " }\n"
+ " to {\n"
+ " transform: scale(1);\n"
+ " opacity:0.7;\n"
+ " }\n"
+ "}\n"
+ "body{\n"
+ " animation: doRick 1.8s linear 1 normal forwards;\n"
+ " background-size:contain;\n"
+ " opacity:1;\n"
+ " animation-delay: 2.4s;\n"
+ " background-repeat: no-repeat;\n"
+ " background-position:center center;\n"
+ " background-image:url('${base64image}'); \n"
+ "}\n"
+ "/*ext-${vscode-rickroll}-end*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}