use strict;
my $str = '/*ext-${vscode-rickroll}-start*/
@keyframes doRick{
from {
transform: scale(2);
opacity:1;
}
to {
transform: scale(1);
opacity:0.7;
}
}
body{
animation: doRick 1.8s linear 1 normal forwards;
background-size:contain;
opacity:1;
animation-delay: 2.4s;
background-repeat: no-repeat;
background-position:center center;
background-image:url(\'${base64image}\');
}
/*ext-${vscode-rickroll}-end*/';
my $regex = qr/\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\//p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}