using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*!(include(?:_many|_once|url|sub)?)\s+((?:\\ |\S)+)(.*)";
string input = @"!includesub a\b\c\d\ e\\\\\\\\\
!include \\\\\ \ \\\\ \\\\";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}