import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*!(include(?:_many|_once|url|sub)?)\\s+((?:\\\\ |\\S)+)(.*)";
final String string = "!includesub a\\b\\c\\d\\ e\\\\\\\\\\\\\\\\\\ \n"
+ "!include \\\\\\\\\\ \\ \\\\\\\\ \\\\\\\\";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}