package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*!(include(?:_many|_once|url|sub)?)\s+((?:\\ |\S)+)(.*)`)
var str = `!includesub a\b\c\d\ e\\\\\\\\\
!include \\\\\ \ \\\\ \\\\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}