re = /^\s*!(include(?:_many|_once|url|sub)?)\s+((?:\\ |\S)+)(.*)/m
str = '!includesub a\\b\\c\\d\\ e\\\\\\\\\\\\\\\\\\
!include \\\\\\\\\\ \\ \\\\\\\\ \\\\\\\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end