$re = '/^\s*!(include(?:_many|_once|url|sub)?)\s+((?:\\\\ |\S)+)(.*)/m';
$str = '!includesub a\\b\\c\\d\\ e\\\\\\\\\\\\\\\\\\
!include \\\\\\\\\\ \\ \\\\\\\\ \\\\\\\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);