#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(000|666|9))\d{3}-?(?!(00))\d{2}-?(?!(0000))\d{4}$"
Local $sString = "//valid" & @CRLF & _
"123-45-6789" & @CRLF & _
"123456789" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"000-00-0000" & @CRLF & _
"123-00-1234" & @CRLF & _
"123-45-0000" & @CRLF & _
"000123456" & @CRLF & _
"123006789" & @CRLF & _
"123450000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")