const regex = /^(?!(000|666|9))\d{3}-?(?!(00))\d{2}-?(?!(0000))\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(000|666|9))\\d{3}-?(?!(00))\\d{2}-?(?!(0000))\\d{4}$', 'gm')
const str = `//valid
123-45-6789
123456789
//invalid
000-00-0000
123-00-1234
123-45-0000
000123456
123006789
123450000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}