$re = '/^(?!(000|666|9))\d{3}-?(?!(00))\d{2}-?(?!(0000))\d{4}$/m';
$str = '//valid
123-45-6789
123456789
//invalid
000-00-0000
123-00-1234
123-45-0000
000123456
123006789
123450000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);