import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(000|666|9))\\d{3}-?(?!(00))\\d{2}-?(?!(0000))\\d{4}$";
final String string = "//valid\n"
+ "123-45-6789\n"
+ "123456789\n\n"
+ "//invalid\n"
+ "000-00-0000\n"
+ "123-00-1234\n"
+ "123-45-0000\n"
+ "000123456\n"
+ "123006789\n"
+ "123450000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}