# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(000|666|9))\d{3}-?(?!(00))\d{2}-?(?!(0000))\d{4}$"
test_str = ("//valid\n"
"123-45-6789\n"
"123456789\n\n"
"//invalid\n"
"000-00-0000\n"
"123-00-1234\n"
"123-45-0000\n"
"000123456\n"
"123006789\n"
"123450000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.