package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+[1-9]\d{1,14}$`)
var str = `754-3010
(541) 754-3010
+1-541-754-3010
1-541-754-3010
+15417543010
001-541-754-3010
191 541 754 3010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}