re = /^\+[1-9]\d{1,14}$/m
str = '754-3010
(541) 754-3010
+1-541-754-3010
1-541-754-3010
+15417543010
001-541-754-3010
191 541 754 3010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end