$re = '/^\+[1-9]\d{1,14}$/m';
$str = '754-3010
(541) 754-3010
+1-541-754-3010
1-541-754-3010
+15417543010
001-541-754-3010
191 541 754 3010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);