import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+[1-9]\\d{1,14}$";
final String string = "754-3010\n"
+ "(541) 754-3010\n"
+ "+1-541-754-3010\n"
+ "1-541-754-3010\n"
+ "+15417543010\n"
+ "001-541-754-3010\n"
+ "191 541 754 3010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}