using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(^0+(\.0+)?$))^\d{1,4}(\.\d{1,2})?$";
string input = @"0000.01
9999.99
1000.09
987.98
99888.82
9999
00.00
0000.00
000.0
000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}