$re = '/(?!(^0+(\.0+)?$))^\d{1,4}(\.\d{1,2})?$/m';
$str = '0000.01
9999.99
1000.09
987.98
99888.82
9999
00.00
0000.00
000.0
000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);