import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(^0+(\\.0+)?$))^\\d{1,4}(\\.\\d{1,2})?$";
final String string = "0000.01\n"
+ "9999.99\n"
+ "1000.09\n"
+ "987.98\n"
+ "99888.82\n"
+ "9999\n"
+ "00.00\n"
+ "0000.00\n"
+ "000.0\n"
+ "000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}