import re
regex = re.compile(r"(?!(^0+(\.0+)?$))^\d{1,4}(\.\d{1,2})?$", flags=re.MULTILINE)
test_str = ("0000.01\n"
"9999.99\n"
"1000.09\n"
"987.98\n"
"99888.82\n"
"9999\n"
"00.00\n"
"0000.00\n"
"000.0\n"
"000\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")