using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<h4><a [^>]*\bhref\s*=\s*""\s*([^""]*)\s*"".*";
string input = @"<h4><a href=""somelinkhere"" class=""search_result_title"" title=""sometitle"" data-followable=""true"">Some Text Here</a></h4><h4><a href=""somelinkhere"" class=""search_result_title"" title=""sometitle"" data-followable=""true"">Some Text Here</a></h4>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}