import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)<h4><a [^>]*\\bhref\\s*=\\s*\"\\s*([^\"]*)\\s*\".*";
final String string = "<h4><a href=\"somelinkhere\" class=\"search_result_title\" title=\"sometitle\" data-followable=\"true\">Some Text Here</a></h4><h4><a href=\"somelinkhere\" class=\"search_result_title\" title=\"sometitle\" data-followable=\"true\">Some Text Here</a></h4>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}