re = /(?i)<h4><a [^>]*\bhref\s*=\s*"\s*([^"]*)\s*".*/m
str = '<h4><a href="somelinkhere" class="search_result_title" title="sometitle" data-followable="true">Some Text Here</a></h4><h4><a href="somelinkhere" class="search_result_title" title="sometitle" data-followable="true">Some Text Here</a></h4>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end