// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)<h4><a [^>]*\bhref\s*=\s*"\s*([^"]*)\s*".*"#).unwrap();
let string = "<h4><a href=\"somelinkhere\" class=\"search_result_title\" title=\"sometitle\" data-followable=\"true\">Some Text Here</a></h4><h4><a href=\"somelinkhere\" class=\"search_result_title\" title=\"sometitle\" data-followable=\"true\">Some Text Here</a></h4>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}