const regex = /(?i)<h4><a [^>]*\bhref\s*=\s*"\s*([^"]*)\s*".*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<h4><a [^>]*\\bhref\\s*=\\s*"\\s*([^"]*)\\s*".*', 'gm')
const str = `<h4><a href="somelinkhere" class="search_result_title" title="sometitle" data-followable="true">Some Text Here</a></h4><h4><a href="somelinkhere" class="search_result_title" title="sometitle" data-followable="true">Some Text Here</a></h4>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}