# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Examples of fruits are (?:(?P<fruits>bananas|apples|grapes|pears)[,]?[\s]?)+ and ((?!\1)(?&fruits))\.$/$1\n/gm;t' <<< "Examples of fruits are bananas, pears and grapes."