import re
regex = re.compile(r"^Examples of fruits are (?:(?P<fruits>bananas|apples|grapes|pears)[,]?[\s]?)+ and ((?!\1)(?&fruits))\.$", flags=re.MULTILINE)
test_str = "Examples of fruits are bananas, pears and grapes."
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)