use strict;
my $str = 'Examples of fruits are bananas, pears and grapes.';
my $regex = qr/^Examples of fruits are (?:(?P<fruits>bananas|apples|grapes|pears)[,]?[\s]?)+ and ((?!\1)(?&fruits))\.$/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";