using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Examples of fruits are (?:(?P<fruits>bananas|apples|grapes|pears)[,]?[\s]?)+ and ((?!\1)(?&fruits))\.$";
string substitution = @"$1\n";
string input = @"Examples of fruits are bananas, pears and grapes.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}