#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Examples of fruits are (?:(?P<fruits>bananas|apples|grapes|pears)[,]?[\s]?)+ and ((?!\1)(?&fruits))\.$"
Local $sString = "Examples of fruits are bananas, pears and grapes."
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)