# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=([a-z])|\d)(?=(?(1)\d|[a-z]))/ /gmi;t' <<< "subject101
street45
45hgh"