const regex = new RegExp('(?<=([a-z])|\\d)(?=(?(1)\\d|[a-z]))', 'gmi')
const str = `subject101
street45
45hgh`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);