use strict;
my $str = 'subject101
street45
45hgh';
my $regex = qr/(?<=([a-z])|\d)(?=(?(1)\d|[a-z]))/mip;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";