#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=([a-z])|\d)(?=(?(1)\d|[a-z]))"
Local $sString = "subject101" & @CRLF & _
"street45" & @CRLF & _
"45hgh"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)