#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^begin\b.*(?:\r?\n(?!end|.*\bkey\b).*)*\r?\nend$"
Local $sString = "begin" & @CRLF & _
"test" & @CRLF & _
"stuff here" & @CRLF & _
"1234" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"begin" & @CRLF & _
"other stuff" & @CRLF & _
"key" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")