$re = '/^begin\b.*(?:\r?\n(?!end|.*\bkey\b).*)*\r?\nend$/m';
$str = 'begin
test
stuff here
1234
end
begin
other stuff
key
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);