import re
regex = re.compile(r"^begin\b.*(?:\r?\n(?!end|.*\bkey\b).*)*\r?\nend$", flags=re.MULTILINE)
test_str = ("begin\n"
"test\n"
"stuff here\n"
"1234\n"
"end\n\n"
"begin\n"
"other stuff\n"
"key\n"
"end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")