import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^begin\\b.*(?:\\r?\\n(?!end|.*\\bkey\\b).*)*\\r?\\nend$";
final String string = "begin\n"
+ "test\n"
+ "stuff here\n"
+ "1234\n"
+ "end\n\n"
+ "begin\n"
+ "other stuff\n"
+ "key\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}