const regex = /^begin\b.*(?:\r?\n(?!end|.*\bkey\b).*)*\r?\nend$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^begin\\b.*(?:\\r?\\n(?!end|.*\\bkey\\b).*)*\\r?\\nend$', 'gm')
const str = `begin
test
stuff here
1234
end
begin
other stuff
key
end`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}