# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\/\K[^\/\r\n]*\/[^\/\r\n]*$/;$0/gm;t' <<< "/testNAS/questions/ask/test/example/picture.png
"