using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*/\K[^/\r\n]*/[^/\r\n]*$";
string substitution = @";$0";
string input = @"/testNAS/questions/ask/test/example/picture.png
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}