import Foundation
let pattern = #"^.*/\K[^/\r\n]*/[^/\r\n]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/testNAS/questions/ask/test/example/picture.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)