$re = '#^.*/\K[^/\r\n]*/[^/\r\n]*$#m';
$str = '/testNAS/questions/ask/test/example/picture.png
';
$subst = ";$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;