#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^"need"\s*:\s*{"A":"(\w+)","B":"(\w+)","C":"(\w+)"}"
Local $sString = ""skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}" & @CRLF & _
""need" : {"A":"ZABCD123","B":"ZABCD1234","C":"ZABCD1235"}" & @CRLF & _
""ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")