// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"need"\s*:\s*{"A":"(\w+)","B":"(\w+)","C":"(\w+)"}"#).unwrap();
let string = "\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}
\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C\":\"ZABCD1235\"}
\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}