import re
regex = re.compile(r"^\"need\"\s*:\s*{\"A\":\"(\w+)\",\"B\":\"(\w+)\",\"C\":\"(\w+)\"}", flags=re.MULTILINE)
test_str = ("\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}\n"
"\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C\":\"ZABCD1235\"}\n"
"\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")