const regex = /^"need"\s*:\s*{"A":"(\w+)","B":"(\w+)","C":"(\w+)"}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^"need"\\s*:\\s*{"A":"(\\w+)","B":"(\\w+)","C":"(\\w+)"}', 'gm')
const str = `"skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}
"need" : {"A":"ZABCD123","B":"ZABCD1234","C":"ZABCD1235"}
"ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}