import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"need\"\\s*:\\s*\\{\"A\":\"(\\w+)\",\"B\":\"(\\w+)\",\"C\":\"(\\w+)\"\\}";
final String string = "\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}\n"
+ "\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C\":\"ZABCD1235\"}\n"
+ "\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}