use strict;
my $str = 'a reasons first_name keep waking up at night, is blah blah blah. Try this, let first_name know and see blah blah blah. Remember that first_name enjoy being challenged and blah blah blah';
my $regex = qr/(?:\b)(?!let)(?=\w+\sfirst_name\s+(know|keep|enjoy))(\w+ \w+)\s+(\w+)/p;
my $subst = '\\2 _object_s';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";